Настройка Ethernet Ring Protection Protocol (ERPS) на коммутаторах D-Link

В этом примере используются коммутаторы cо стандартным CLI D-Link DGS-3130-30TS. 

Ethernet Ring Protection Switching (ERPS) защищает от петель коммутации в сетях Ethernet с кольцевой топологией, обеспечивая при этом отказоустойчивость сети.

В протоколе ERPS используются следующие понятия и термины:

  • RPL (Ring Protection Link) —  резервный линк между коммутаторами, который будет заблокирован механизмом ERPS при нормальном режиме работы кольца.
  • RPL Owner —  коммутатор, подключенный к RPL, который блокирует этот линк при нормальном режиме работы кольца и разблокирует его при разрыве кольца.
  • R-APS (Ring-Automatic Protection Switching) —  протокол обмена сообщениями, определенный в Y.1731 и в G.8032. Используется для координации действий по защите кольца. Сообщения R-APS передаются в RAPS VLAN.
  • RAPS VLAN (A-RPS Channel) —  специальная VLAN, по которой будет передаваться служебная информация.
  • Protected VLAN —  остальные VLAN, проходящие по кольцу.

Один из коммутаторов настраивается как RPL owner и один из его кольцевых портов назначается RPL-портом, на котором трафик будет блокироваться. Если на одном из остальных коммутаторов на кольцевом порту пропадёт связь, этот коммутатор пошлёт служебное сообщение об обрыве через работающий порт и тем самым известит RPL owner’а и тот включит заблокированный порт.

Приведу настройки вот для такой схемы сети:

Схема сети
Схема сети

Коммутатор SW1 — RPL owner

Collapse )

Сохранение и просмотр файлов в памяти коммутатора D-Link

Применимо для коммутаторов D-Link со стандартным CLI.
Например, DGS-3130

Во время настройки коммутатора все изменения сохраняются в оперативной памяти. И чтобы они не потерялись после перезагрузки коммутатора, нужно не забыть эти изменения сохранить в энергонезависимой памяти. Делается это при помощи команды copy running-config startup-config.

Но иногда бывает удобно сохранять конфигурацию на в startup-config, а в файле на флеш-памяти коммутатора: copy running-config flash: <имя_файла>

Посмотреть, какие файлы были сохранены, можно командой dir

А прочитать конкретный файл позволит команда more

Чтобы заменить текущую конфигурацию конфигурацией из файла, нужно сначала очистить текущую конфигурацию, а затем скопировать в нее конфигурацию из файла: 

clear running-config
copy flash: <имя_файла> running-config


Настройка traffic segmentation на коммутаторах D-Link DGS-3130

При помощи функции traffic segmentation (сегментация трафика) можно  настроить порты или группы портов коммутатора таким образом, чтобы они были полностью изолированы друг от друга, но в то же время имели доступ к разделяемым портам, используемым для подключения серверов или магистрали сети. 

Схема сети
Схема сети
Collapse )

Настройка DHCP-cервера на коммутаторе D-Link

Тут и тут описывалось, как настроить на коммутаторах D-Link DHCP Relay. Теперь же покажу, как настроить на коммутаторе DHCP сервер.

По умолчания на коммутаторе есть VLAN 1. В этом примере DHCP-сервер будет работать на ip-интерфейсе этой VLAN.

Настраиваем ip-адрес на интерфейсе vlan 1:

SW1(config)# interface vlan 1
SW1(config-if)# ip address 192.168.30.1 255.255.255.0
SW1(config-if)# exit

Настраиваем пул адресов DHCP:

SW1(config)# ip dhcp pool pool1
SW1(config-dhcp-pool)# network 192.168.30.0/24
SW1(config-dhcp-pool)# default-router 192.168.3.1
SW1(config-dhcp-pool)# dns-server 8.8.8.8
SW1(config-dhcp-pool)# exit

Указываем, какие ip-адреса не надо выдавать клиентам (диапазон 192.168.30.1 192.168.30.5) :

SW1(config)# ip dhcp excluded-address 192.168.30.1 192.168.30.5

Запускаем сервис DHCP:

SW1(config)#service dhcp

Посмотреть выданные клиентам адреса можно про помощи команды:

SW1# show ip dhcp binding
Просмотр адресов, выданных DHCP-сервером
Просмотр адресов, выданных DHCP-сервером

В этом примере использовался коммутатор D-Link DGS-3130-30TS

Разные типы CLI на коммутаторах D-Link

На данный момент на управляемых коммутаторах D-Link существует два типа интерфейса командной строки (CLI): D-Link CLI и стандартный CLI. Стандартный CLI ранее мог называться «industrial-like» или «Cisco-like» CLI.

Вот два примера настройки DHCP Relay: на коммутаторе с D-Link CLI и со стандартным CLI.

Сейчас D-Link CLI поддерживается на следующих сериях коммутаторов:

  • DGS-1100/ME
  • DGS-1210/ME
  • DGS-1210
  • DGS-3000

А стандартный CLI поддерживается на этих сериях:

  • DGS-1250
  • DGS-1510
  • DXS-1210
  • DXS-3400
  • DGS-3130
  • DGS-3630
  • DXS-3610

Как видите, все новые серии коммутаторов D-Link — уже со стандартным CLI.

Настройка VLAN и агрегирования портов на коммутаторе D-Link DGS-3130

Рассмотрим такую схему:

Схема сети
Схема сети

У нас есть два коммутатора D-Link DGS-3130-30TS. Нужно настроить на каждом по две дополнительных VLAN и связать коммутаторы через два порта 10G (порты 25-26), агрегировав их пропускную способность.

Switch 1

Настраиваем VLAN:

SW1(config)# vlan 2
SW1(config-vlan)# name v2  
SW1(config-vlan)# exit  
SW1(config)# vlan 3  
SW1(config-vlan)# name v3  
SW1(config-vlan)# exit
SW1(config)# interface range ethernet 1/0/1-12  
SW1(config-if-range)# switchport mode access  
SW1(config-if-range)# switchport access vlan 2  
SW1(config-if-range)# exit  
SW1(config)# interface range ethernet 1/0/13-24  
SW1(config-if-range)# switchport mode access  
SW1(config-if-range)# switchport access vlan 3
SW1(config-if-range)# exit   

Настраиваем агрегирование:

SW1(config)# interface range ethernet 1/0/25-26  
SW1(config-if-range)# channel-group 1 mode active  
SW1(config-if-range)# exit 

Добавляем агрегированный канал в VLAN как транк:

SW1(config)# interface port-channel 1  
SW1(config-if)# switchport mode trunk  
SW1(config-if)# switchport trunk allowed vlan 2, 3

Switch 2

Collapse )

Gratuitous ARP. Настройка на коммутаторах D-Link DGS-3130

Gratuitous — в переводе с английского означает «беспричинный». Так он называется потому что это ответ на предполагаемый запрос, которого на самом деле не было, т.е. он отправляется как бы «без причины».

Gratuitous ARP представляет собой или пакет ARP Request, или пакет ARP Reply, который широковещательно отправляется узлом, чтобы уведомить другие узлы о необходимости обновить записи в их ARP-таблицах.

В сети Gratuitous ARP может использоваться для:

  • определения дублирования IP-адресов;
  • оповещения, что IP-адрес привязан к новому МАС-адресу;
  • уведомления коммутаторов, что узел был переключен с одного порта на другой.

На коммутаторах D-Link серии DGS-3130 со стандартным CLI функция настраивается так.

Включение механизма Gratuitous ARP:

Switch(config)# ip gratuitous-arps

Включение обнаружения дублирования IP-адресов:

Switch(config)# ip gratuitous-arps dad-reply

Настройка интервала отправки сообщений Gratuitous ARP request (по умолчанию значение 0) на интерфейсе vlan 1:

Switch(config)# interface vlan 1
Switch(config-if)# arp gratuitous-send interval 5

Проверить сделанные настройки можно при помощи команд:

Switch# show   running-config | include log
Switch# show   running-config | include arp

Настройка RSTP на коммутаторах D-Link серии DGS-3130

В предыдущем посте была рассмотрена настройка протокола STP на коммутаторах D-Link DGS-3130. 

Протокол Rapid Spanning Tree Protocol (RSTP) является развитием протокола STP и в настоящее время определен в стандарте IEEE 802.1D-2004 (ранее был определен в стандарте IEEE 802.1w-2001). Протокол RSTP значительно уменьшает время сходимости коммутируемой сети за счет мгновенного перехода корневых и назначенных портов в состояние продвижения.

В RSTP вводятся новые роли портов:

  • Альтернативный порт (Alternate port, AP) - это заблокированный порт, который получает BPDU с лучшими параметрами от другого коммутатора. Это резервная копия корневого порта;
  • Резервный порт (Backup port, BP) - это заблокированный порт, который получает BPDU с лучшими параметрами от того же коммутатора. Это резервная копия назначенного порта;
  • Граничный порт (Edge port, EP) – это порт, подключенный к конечной станции, а не к другому коммутатору. Не участвует в построении дерева STP и теряет статус граничного порта, если получает BPDU.
Роли портов RSTP
Роли портов RSTP
Collapse )

Настройка STP на коммутаторах D-Link серии DGS-3130

Для обеспечения отказоустойчивости между коммутаторами нужно создать несколько резервных соединений. Но при этом в сети возникнут коммутационные петли, если не использовать дополнительные алгоритмы решения этой проблемы. Одно из средств, которое позволяет избавиться от таких петель и связанных с этим проблем — это использование на коммутаторах протокола Spanning Tree.

Протокол связующего дерева Spanning Tree Protocol (STP) является протоколом 2 уровня модели OSI, который:

  • позволяет строить древовидные, свободные от петель, конфигурации связей между коммутаторами локальной сети; 
  • обеспечивает возможность автоматического резервирования альтернативных каналов связи между коммутаторами на случай выхода активных каналов из строя.  

В настоящее время существуют три версии протоколов связующего дерева:

  • IEEE 802.1D Spanning Tree Protocol (STP); 
  • IEEE 802.1w Rapid Spanning Tree Protocol (RSTP);
  • IEEE 802.1s Multiple Spanning Tree Protocol (MSTP).

Для построения активной топологии с использованием STP в сети выбирается корневой коммутатор, от которого строится всё дерево. Корневым становится коммутатор с наименьшим значением идентификатора Bridge ID. 

Bridge ID состоит из двух частей: 2 байта приоритета (по умолчанию равен 32768) и 6 байт МАС-адреса коммутатора. Настраивая приоритет коммутатора (уменьшая его) администратор может повлиять на то, какой именно коммутатор станет корневым (RB). Все остальные коммутаторы будут некорневыми (NRB).

Collapse )