computronium

Настройка DHCP Relay на коммутаторах D-Link с industrial-like CLI

Здесь описывалась настройка DHCP Relay на коммутаторе D-Link DGS-3000. У коммутаторов D-Link серий DGS-1510, DGS-3130, DXS-3600 другой тип командной строки — так называемый industrial-like CLI.

Рассмотрим пример настройки DHCP Relay для таких коммутаторов. В нашем примере — две VLAN для сотрудников и гостей, DHCP-сервер находится в VLAN 1. 

  • VLAN 1: сеть 192.168.1.0/24 
  • VLAN 10: сеть 192.168.10.0/24 
  • VLAN 20: сеть 192.168.20.0/24 
  • DHCP-сервер IP: 192.168.1.100 
  • DHCP-сервер в VLAN 1 
  • Host1 в VLAN 10
  • Host2  в VLAN 20 

Шаг 1.
Создаем VLAN и настраиваем IP-интерфейсы для каждой VLAN. В этом примере настраиваем адрес  192.168.10.90 для VLAN 10 и 192.168.20.90 для VLAN  20.

Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.90 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.20.90 255.255.255.0
Switch(config-if)#exit

Шаг 2.
Определеяем порты в VLAN. В этом примере порт 7 в VLAN 10,  порт 8 в VLAN 20 и DHCP сервер на порту 24 в VLAN 1.

Switch(config)#interface ethernet 1/0/7
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface ethernet 1/0/8
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface ethernet 1/0/24
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1
Switch(config-if)#exit 

Шаг 3.
 

Включаем DHCP relay и командой relay source указываем исходную подсеть клиентских запросов и командой relay destination указываем адрес сервера назначения ретрансляции. И затем сохраняем конфигурацию. 

Switch(config)#service dhcp
Switch(config)#ip dhcp relay information option
Switch(config)#ip dhcp pool corporate
Switch(config-dhcp-pool)#relay source 192.168.10.90 255.255.255.0
Switch(config-dhcp-pool)#relay destination 192.168.1.100
Switch(config-dhcp-pool)#exit
Switch(config)#ip dhcp pool guest
Switch(config-dhcp-pool)#relay source 192.168.20.90 255.255.255.0
Switch(config-dhcp-pool)#relay destination 192.168.1.100
Switch(config-dhcp-pool)#
Switch#copy run start
Destination filename startup-config? [y/n]:  y
Saving all configurations to NV-RAM.......... Done.

Error

Anonymous comments are disabled in this journal

default userpic